author | renatofilho |
Tue Aug 21 16:04:44 2007 +0100 (2007-08-21) | |
branch | trunk |
changeset 815 | 7f290a3a34b1 |
permissions | -rwxr-xr-x |
1 #!/usr/bin/make -f
2 # -*- makefile -*-
4 # Uncomment this to turn on verbose mode.
5 #export DH_VERBOSE=1
7 PYVER=2.5
8 PYTHON=python$(PYVER)
10 PREFIX=debian/tmp
12 build: build-stamp
14 build-stamp:
15 touch build-stamp
17 clean:
18 dh_testdir
19 dh_testroot
20 rm -f build-stamp
21 dh_clean
23 install: build
24 dh_testdir
25 dh_testroot
26 dh_installdirs
27 dh_clean -k
29 @rm -rf build
30 @$(PYTHON) setup.py install --prefix=$(PREFIX)/usr --no-compile --install-purelib=$(PREFIX)/usr/share/gms
31 install -D -o root -g root -m 755 $(PREFIX)/usr/etc/init.d/gmsd debian/$(cdbs_curpkg)/etc/init.d/gmsd
32 install -D -o root -g root -m 755 $(PREFIX)/usr/etc/gms/server.conf debian/$(cdbs_curpkg)/etc/gms/server.conf
34 dh_install
36 # Build architecture-independent files here.
37 binary-indep: build install
38 dh_testdir
39 dh_testroot
40 dh_installchangelogs
41 dh_installdocs
42 dh_strip
43 dh_compress
44 dh_fixperms
45 dh_installdeb
46 dh_gencontrol
47 dh_md5sums
48 dh_builddeb
50 binary: binary-indep
51 .PHONY: clean binary-indep binary install