renatofilho@608: #! /bin/sh
renatofilho@608: set -e
renatofilho@608: 
renatofilho@608: #DEBHELPER#
renatofilho@608: 
renatofilho@608: # Register our X Desktop Group Shared MIME-info Database info
renatofilho@608: if [ -x /usr/bin/update-mime-database ] ; then
renatofilho@608:         /usr/bin/update-mime-database /usr/share/mime
renatofilho@608: fi
renatofilho@608: 
renatofilho@608: # Register a new type on Osso Media Server
renatofilho@608: if [ -x /usr/bin/gconftool-2 ] ; then
renatofilho@608:     /usr/bin/gconftool-2 --makefile-install-rule /usr/share/gconf/schemas/osso_media_server_nuv.schemas
renatofilho@608: fi
renatofilho@608: 
renatofilho@608: #append nuv info on osso mediaplayer ui
renatofilho@608: data_file=/usr/share/applications/hildon/mp_ui.desktop
renatofilho@608: tmp_file=/tmp/mp_ui.desktop
renatofilho@608: cat $data_file | sed 's/X-Osso-URI-Actions=rtsp/X-Osso-URI-Actions=rtsp;myth/' | sed 's/MimeType=\(.*\)/MimeType=\1;video\/x-nuv/'  > $tmp_file
renatofilho@608: echo -e "\n\n[X-Osso-URI-Action Handler myth] \nMethod=mime_open\nName=medi_ap_mediaplayer_name\nTranslationDomain=mediaplayer" >> $tmp_file
renatofilho@608: cat $tmp_file > $data_file
renatofilho@608: echo "FILE DESKTOP UPDATED"
renatofilho@608: 
renatofilho@608: exit 0