renatofilho@815: #! /bin/sh
renatofilho@815: # postinst script for gms
renatofilho@815: 
renatofilho@815: set -e
renatofilho@815: 
renatofilho@815: case "$1" in
renatofilho@815:   configure)
renatofilho@815:     if ! getent passwd gms >/dev/null; then
renatofilho@815:       adduser --disabled-password  --quiet --system \
renatofilho@815:         --home /var/gms-media \
renatofilho@815:         --gecos "GMS media dir" --group gms
renatofilho@815:     fi
renatofilho@815:     if ! getent passwd gms | grep -q /var/run/gms; then
renatofilho@815:         usermod -d /var/gms-media gms
renatofilho@815:     fi
renatofilho@815:     update-rc.d gmsd defaults
renatofilho@815:     invoke-rc.d gmsd start
renatofilho@815:   ;;
renatofilho@815:   abort-upgrade|abort-remove|abort-deconfigure)
renatofilho@815:   ;;
renatofilho@815:   *)
renatofilho@815:     echo "postinst called with unknown argument \`$1'" >&2
renatofilho@815:     exit 1
renatofilho@815:   ;;
renatofilho@815: esac
renatofilho@815: 
renatofilho@815: #DEBHELPER#
renatofilho@815: 
renatofilho@815: exit 0