renatofilho@815: #!/usr/bin/make -f
renatofilho@815: # -*- makefile -*-
renatofilho@815: 
renatofilho@815: # Uncomment this to turn on verbose mode.
renatofilho@815: #export DH_VERBOSE=1
renatofilho@815: 
renatofilho@815: PYVER=2.5
renatofilho@815: PYTHON=python$(PYVER)
renatofilho@815: 
renatofilho@815: PREFIX=debian/tmp
renatofilho@815: 
renatofilho@815: build: build-stamp
renatofilho@815: 
renatofilho@815: build-stamp:
renatofilho@815: 	touch build-stamp
renatofilho@815: 
renatofilho@815: clean:
renatofilho@815: 	dh_testdir
renatofilho@815: 	dh_testroot
renatofilho@815: 	rm -f build-stamp
renatofilho@815: 	dh_clean
renatofilho@815: 
renatofilho@815: install: build
renatofilho@815: 	dh_testdir
renatofilho@815: 	dh_testroot
renatofilho@815: 	dh_installdirs
renatofilho@815: 	dh_clean -k
renatofilho@815: 
renatofilho@815: 	@rm -rf build
renatofilho@815: 	@$(PYTHON) setup.py install --prefix=$(PREFIX)/usr --no-compile --install-purelib=$(PREFIX)/usr/share/gms
renatofilho@815: 	install -D -o root -g root -m 755 $(PREFIX)/usr/etc/init.d/gmsd  debian/$(cdbs_curpkg)/etc/init.d/gmsd
renatofilho@815: 	install -D -o root -g root -m 755 $(PREFIX)/usr/etc/gms/server.conf  debian/$(cdbs_curpkg)/etc/gms/server.conf
renatofilho@815: 
renatofilho@815: 	dh_install
renatofilho@815: 
renatofilho@815: # Build architecture-independent files here.
renatofilho@815: binary-indep: build install
renatofilho@815: 	dh_testdir
renatofilho@815: 	dh_testroot
renatofilho@815: 	dh_installchangelogs
renatofilho@815: 	dh_installdocs
renatofilho@815: 	dh_strip
renatofilho@815: 	dh_compress
renatofilho@815: 	dh_fixperms
renatofilho@815: 	dh_installdeb
renatofilho@815: 	dh_gencontrol
renatofilho@815: 	dh_md5sums
renatofilho@815: 	dh_builddeb
renatofilho@815: 
renatofilho@815: binary: binary-indep
renatofilho@815: .PHONY: clean binary-indep binary install
renatofilho@815: