diff -r 000000000000 -r 372e7c8135b9 gst-gmyth/debian/maemo-nuvdemux.postinst
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/gst-gmyth/debian/maemo-nuvdemux.postinst	Mon Jul 02 09:18:52 2007 +0100
@@ -0,0 +1,24 @@
+#! /bin/sh
+set -e
+
+#DEBHELPER#
+
+# Register our X Desktop Group Shared MIME-info Database info
+if [ -x /usr/bin/update-mime-database ] ; then
+        /usr/bin/update-mime-database /usr/share/mime
+fi
+
+# Register a new type on Osso Media Server
+if [ -x /usr/bin/gconftool-2 ] ; then
+    /usr/bin/gconftool-2 --makefile-install-rule /usr/share/gconf/schemas/osso_media_server_nuv.schemas
+fi
+
+#append nuv info on osso mediaplayer ui
+data_file=/usr/share/applications/hildon/mp_ui.desktop
+tmp_file=/tmp/mp_ui.desktop
+cat $data_file | sed 's/X-Osso-URI-Actions=rtsp/X-Osso-URI-Actions=rtsp;myth/' | sed 's/MimeType=\(.*\)/MimeType=\1;video\/x-nuv/'  > $tmp_file
+echo -e "\n\n[X-Osso-URI-Action Handler myth] \nMethod=mime_open\nName=medi_ap_mediaplayer_name\nTranslationDomain=mediaplayer" >> $tmp_file
+cat $tmp_file > $data_file
+echo "FILE DESKTOP UPDATED"
+
+exit 0